Linode: Update your ArchLinux VPS

connect 2 sessions on your Linode

 

On the second, run this:

dd if=/dev/urandom of=/dev/null

 

on the first one, do the following:

pacman-key --init

 

You can stop the dd process on the second connnection

pacman-key --populate archlinux

pacman-key --refresh-keys

 

Update pacman

pacman -Sy pacman

 

Update your installation

pacman -Syu

 

Enjoy a quick cofee

 

That should do it

 

 

 

 

(gs)MT- REQUEST ID #670588 / STATUS: Resolved

Rob C.

Thank you for the phone call. Here is a brief summary of our conversation:

You called in to report that your Postgres server was not working. Your web application was displaying error messages, you couldn’g connect via the command-line and phpPgAdmin was not working. I notified an engineer and they are taking a look at it. I’ll be calling you back this evening to let you know the status.

If you have any further questions regarding your (mt) Media Temple services, please feel free to contact us at any time.

Best Regards,

Rob C.
Customer Support
(mt) Media Temple
<v> 877-578-4000
<f> 310-564-2007

NEW! User Forums: http://kb.mediatemple.net/questions/824/

@
2009.10.08 09:51 PM
Maurício

I have posted a screen capture here:
http://portnumber53.com/images/alocate_memory.jpg

waiting for your call back

@
2009.10.08 09:54 PM
Rob C.

Thank you for the phone call. Here is a brief summary of our conversation:

You had some concerns you wanted addressed during our call:

1) Regarding support request #657283 you’d like to know if the problem with pg_dump versions has been fixed because you want to move back to the Smart Pool and are concerned about database corruption.

2) Your Container that has both MySQL and Postgres running ran into problems tonight and had to be rebooted. You’ve had the same application error displayed in the Smart Pool, after you were bursted and in a Container. I’m going to see if we have any Postgres server logs available.

3) You’d like someone to call you back about these issues.

If you have any further questions regarding your (mt) Media Temple services, please feel free to contact us at any time.

Best Regards,

Rob C.
Customer Support
(mt) Media Temple
<v> 877-578-4000
<f> 310-564-2007

NEW! User Forums: http://kb.mediatemple.net/questions/824/

@
2009.10.08 11:07 PM
Maurício

just a small detail, I had the same issues regardless the application I was using (psql, pg_dump, phpPgAdmin) in both the Smart Pool and the Grid Container.
None of my "Postgresql websites" have big databases (or tables) and they don’t have high traffic usage at the moment.

@
2009.10.08 11:25 PM
Mike M.

The application is giving errors about the environment being out of memory. This message can happen in the Smartpool or the Container because you are exhausting all the resources avaliable. The Postgres error logs have been put in the /backup directory and this information can be viewed via the Account Center File Manager. I would advise to look over this information in regards to optimizing the environment. If you need any further insight please to not hesitate to ask.

Best Regards,

Mike M
Customer Support
Check out the New User Forums: http://kb.mediatemple.net/questions/824/
(mt) Media Temple
<v> 877-578-4000
<f> 310-564-2007

@
2009.10.09 05:41 AM

Storage problems when my account was on Cluster 02

Last year (2008), MediaTemple was having a lot of issues with their Cluster 02, which meant my websites (and everyone’s) on the cluster would be unavailable several times. After struggling for months they were able to narrow the problems to a defective segment of their storage components. By then I had spent hours on the phone with them, noticed that Cluster 01 would also have its issues; but I never saw any issues issues with Cluster 03.

It was then, that occurred to me to ask them to move my account to said cluster!

Unfortunatelly they couldn’t do it automagically, which I was ok with doing manually since they gave me an one month credit to do so. Great so far.

If I remember right, I managed to move everything working late hours spread over 2 nights. Since all the transfers were inside their network I’d get speed transfers liks 30MB/s which really saves a *lot* of time.

First *HUGE* problem.

Right after I moved and had everything working on the new (gs) on Cluster 03, I called them to expedite the old (gs)cancellation. That was when the technician clicked the wrong (gs) and deleted the new (gs) server… Need I say I yelled at him?

Well, he said he would escalate my ticket to the administrators to have them restore my server from their graveyard (he said they mantain the data somewhere else even after cancelling accounts, probably, for cases like this one). When I asked when that ticket would be processed, he game the standard "ASAP" response. And I said…. Wait! You deleted my account and now I have to wait??

Around 4 hours later (the administrator was having lunch and no one else was taking care of their hundreds of thousands of customers), I finally have my data back.

Now this part, I don’t remember very well, but if my brain is not playing tricks on me, they could not recover everything. And so I still had some tweaks and adjustments to have my websites up and running smoothly again….

At around 11 p.m. that day, I had everything working again…. so I called them to get rid of the now old (gs) server (the one they killed by accident). I asked whoever answered the phone that time to please read the screen very carefully so he wouldn’t kill the wrong (gs) server…. (yes, I tend to be sarcastic)

Whatever he did there…. my server disappeared one more time….  everything was down again….

At this point I turned into the kind of customer that can only ask: "Are you guys playing around there?"

So he has to check went happened and calls me back around 30 minutes later, and said something about simply deactivating the account (as opposed to killing it) and my websites were up and working again.

Customer support until that day had been really helpful and seemed like they knew what they were doing.

From this day, though, I kinda lost confidence and have always argued back.

BTW, I asked for some compensation for the first technician having deleted my (gs) and that almost happening a second time, no administrator present to solve my problem. I got 1 month of credit….. NOT A YEAR, SIMPLY 1 MONTH CREDIT.  That’s how important my websites and data are…. $20 for MediaTemple.

MediaTemple: my new opinion about the (gs) GridServer

After having lots of headaches with GISOL webhosting back in 2007, I finally stumbled upon Media Temple’s (gs) Grid Server hosting.

They make it sound really great, and it was at the beginning.

But so far these are the problems I ran into with them:

  • Storage problems when my account was on Cluster 02.
  • Account deletion after I manually moved everything from Cluster 02 to another account on Cluster 03
  • Account shortly disabled after I had recovered most of my files on a new account on Cluster 03 after the first was deleted.
  • Storage problems on the Cluster 03 (as annoying as they were on Cluster 02)
  • Postgresql "Cannot allocate memory" errors while running small-databases-low-traffic sites with PostgreSQL databases (hours on the phone trying to get some useful help)

I’ll detail each of those later, since it’s pretty late right now

  • IGlr